A website. With stuff on it.
September 12th, 2008 at 11:44 am
Posted By: Jay
Posted in: Site News

So following a four day email ping pong match with EA’s support chimps, they have closed my case as resolved by telling me to stop running the game on two video cards, stop running it on two cores, and stop running it on my sound hardware, and if I get any problems, get back to them…

Firstly, none of this actually helps, since my initial description was that I cannot save any games or start and save any new games because the single file that links ALL your game saves is corrupt, and they have done absolutely nothing to resolve that.

Secondly, how pathetic is it that I have to disable half the hardware on my pc to run it? I know they started coding it like 6 years ago, but does it only work on six year old pc’s or something?

In fact, apart from SLi, under which it flat refused to run, I ran the game fine for around 70 hours on dual cores with hardware accelerated sound, which really just adds up to EA not knowing what the fuck they’re talking about.

I’m off to download the cracked, DRM free version of Spore now so I can install it without fear of losing an activation trying to get the game working in the first place.  Kinda wish I’d done this as a road test before buying it and saved myself the money in finding out what a flakey pile of crap it is.




1 Comment
  1. Well said.

    Comment by Oona — April 22, 2009 @ 8:09 pm

RSS feed for comments on this post.

Sorry, the comment form is closed at this time.